Printers automatically being added to Mac


(Rick Huisman) #1

We’ve had several Mac users (High Sierra) find that printers have been automatically added to their computer (myself included). They appear to be printers shared from other Macs. Some of these have then caused the printing to be unresponsive. The only way to easily remove the offending printer is to go into CUPS and delete the printer from there.
Anyone run into this? Printer Sharing is already turned off and users have been reminded to not share printers. How else can we stop this from happening again?


(Jeremy Good) #2

Same here. Only started with High Sierra. I have to blow away my printers every week and reinstall them. We’ve tried disabling printer sharing with Jamf but they still keep showing up. Yet more proof that Apple doesn’t think about business.


(Will Polley) #3

When you’re adding printers via lpadmin are you setting the no sharing flag?

We haven’t seen this yet.


(Rick Huisman) #4

We’re not setting up printers via lpadmin. When we do add printers, we don’t mark it as shared and we do check that printer sharing is off. The printers that show up appear to be ones that other users add - like their home printer.


(Russ Taylor) #5

I haven’t played extensively with High Sierra yet, but Macs use protocols other than CUPS for printers. In particular the auto-discovery protocol Bonjour. It may be that your printer is discoverable via Bonjour and you need to turn this protocol off. We have some Oki printers, which appear to add themselves to our Mac network via Bonjour as well as via IP, Ethertalk, Novell, etc. I have had to go into the printer’s own configuration and turn off the ones I don’t want to be used. You may have to do the same.


(Will Polley) #6

You cannot and should not turn off bonjour in macOS.

You should be able to disable printer sharing with a config profile.


(Russ Taylor) #7

I’m not suggesting you should turn off bonjour in MacOS. I am saying you should turn off the un-needed protocols on the printer. If you are using CUPS over IP, you shouldn’t need Bonjour.


(Jason Lee) #8

I came across this little “feature” just last week when i was trying to provide support to a location where we couldn’t get the OSX print driver to work on a Canon copier. Had nothing to do with the canon drivers… wheel of death every time we’d load the system prefs and open printers.

Gordon’s Blah blah printer had installed… and i have NO Idea when i was on a network with Gordon’s printer but sure enough this was giving me fits…
Safe mode Boot, Login as other users… none helped

finally had to run
lpstat -p | cut -d' ' -f2 | xargs -I{} lpadmin -x {}
in terminal and reset the printing system. Kudos to Jamf community board for this help.


(Rick Huisman) #9

We were able to find a computer with this issue and Apple Support. After a long phone call with Apple Support, the technician is sending our case to engineering. Hopefully we’ll hear back from them on this. The command Jason noted is the quickest way so far to clear the problem -especially if you have someone who travels a lot and uses public WiFi. We’re trying to find out how to turn off this Apple “feature”.


(Jason Lee) #10

Sigh… just came back from MPUG2018 and i couldn’t manage printers… sure enough… 5 printers magically had been added to my machine. 20%20PM

So thankful that i can just run the terminal command and then use the one click button to reinstall printers in Jamf.