MP Check in Suite with Brother & Godex Label Printers


(Andy Baker) #1

We are upgrading to the new check in suite soon and we are testing the new Check in suite with a a Brother QL-810W and Godex DT4, and Godex EZDT4 label printers.
Has anyone gotten any of these printers to work in the check in suite?
When we try to print, the light on the Brother QL-810 blinks, and the job in the print queue just says paused and nothing prints.
The local print service is installed correctly and verifies, and the service is running in local services.
BTW, we are testing on a machine running the checkin2 with the JS print extension installed in Firefox.


(Nic) #2

I can’t help too much since I use the dymo labelwriter 450 for the same thing, but I would check your printer layout setting to make sure you have it matching the settings in the checkin admin.


(Patrick Cho) #3

Andy, is there reason why you are using those printer for new Checkin Suite. We are thinking about MP new checkin suite too and I am curious how will works. I am looking into new Dymo Wireless Printer.


(Nic) #4

Patrick- I was thinking about going that route as well. The Dymo LabelWriter 450 Turbo works great with it, so I am assuming that the wireless one will work just as well. Let me know if you get one and how it works.


(Andy Baker) #5

Hi Patrick, we are testing with these printers because we own them and and they are working well with checkin2. I know they are not on the approved list, but they weren’t for checkin2 either, and they work in Firefox with the JS Print plug-in. Thanks for responding.
If we don’t have to buy new printers, we would rather di that than invest in new printers.


(Patrick Cho) #6

I tested with Checkin2 and it seems working, but I haven’t add into production yet. I will add it to production this Sunday and let you guys know.


(Andy Baker) #7

Thanks Patrick. I appreciate it.


(Andy Baker) #8

Thanks Nic,
The Brother we use for checkin2 model QL-810W uses a continuous length label roll, and it cuts it based on the label we created and tested for checkin2. It’s not a fixed size per say like 3X2, etc. The Godex label printers we use are 3X2, I’m going to test that today on a machine that has never had checkin2 installed, so it will be a fresh install of the new check in suite and printer service and I’m going to use Chrome instead of Firefox.
I’ll post back if that works or not.


(Andy Baker) #9

Update on Printing check in tags in the new MP check in suite with a Godex DT4 and Brother QL-810W.
My network admin created a test tag in the new MP check in suite, and we could not get the tags to print correctly on that tag.
I switched over to the default Zebra 3X2, and the tags printed correctly, but were noticeably “rasterized”. The fonts were a bit fuzzy looking, and straight lines appeared to be wavy and broken, as if printed on an old dot matrix printer.
We still have some tweaking to do on our label set obviously, but at least the tags printed.


(Patrick Cho) #10

I tried Dymo Wireless Printer with Checkin2 and didn’t worked. I am not sure if this is wireless issue or the printer.
It was working when I tested from my laptop but not with checkin station. I need to investigate the issue. I will update here once I found out.


(Andy Baker) #11

Thanks for testing Patrick. I too will post back here if/when we get our tags printing correctly with our current label printers in the new check in suite.


(Patrick Cho) #12

Andy, If you don’t mind, how is the new checkin suite works for you? Do you have any advise? We are planning to use it fairly soon. Your input will be great help. Thanks


(Andy Baker) #13

Hey Patrick, we haven’t migrated any of our campuses yet. We are just testing at this point on non production equipment.


(Andy Baker) #14

I had time to do a little more testing earlier today. I was able to get our test tag to print & cut correctly, just had to change the orientation to “Portrait” and check the option for cutter in the label set.
I need to spend more time figuring out how the tokens are laid out and if that is editable. If a child has a lot of allergies, it cuts off the security tag and not all of the allergies print on the tag. Here is an example. I also cannot figure out a setting which allows the text to print clearer in the new check in suite. This was printed on a Godex EZ DT4 3X2 labels.


(Mark Wyse) #15

Following this thread. Please keep the updates coming as we researching
these same things. Thanks!

Mark Wyse
Blackhawk Church


(Andy Baker) #16

I tried configuring the new check in suite connected to one of our spare Windows 10 laptops using a Brother QL-810W and I still could not get it to print a label. At first the green LED light would blink like it knew it was receiving data, but nothing would print.
The print service is configured and I can print a Windows test page on the Brother all day.
The document in the print queue says HIQPDF, and it’s in an error state.


(Andy Baker) #17

According to MP’s supported printer list, currently continuous length printers are not supported in the new check in suite. Our model of Brother, QL-810W is a continuous length label printer. This explains why I couldn’t get it to print.
As far as printing from The Godex printers we use at our campuses, DT4, and EZ-DT4, we plan on
engaging MP professional services to see if it’s possible to make these work in the check in suite.
Going forward we will begin to order label printers on the approved list.
If it’s not possible to get our current label printer inventory working with MP check in suite, then we will need to purchase printers on the approved list. We’re leaning toward one of the approved Zebra models, since we have a lot of 3X2 labels that we have purchased.


(Andy Baker) #18

My network administrator, Geoff Phillips, worked on this issue yesterday and he was able to figure out a couple of settings on one of our Godex EZ-DT4 label printers which allowed the label to print much better in the new check in suite.
Here is what he found.
OK, I think I’ve got the Godex printers to a workable state.

Settings:
Dithering = NONE
Color Adjustments = Brightness -65

Unlike the old Checkin2, which printed text generated through CSS styles, the new Checkin generates an image to print. Oddly, it’s a low (94dpi) RGB image that the Godex driver doesn’t handle well. To print the image, Godex has to upscale it to 204, change it to greyscale and then print. Since our printers don’t really greyscale, that causes weirdness where the edges becomes odd shades of non-grey blur after upscaling. Their greyscale converter then does group averages of those blurred edges, which results in those weird raster jagged edges.

SO, we tell the printer to darken the whole image. It does that before the upscale / greyscale. The blurred edges become much darker, which makes them upscale/greyscale better.

I think that’s what’s happening. Anyway, goofing with fonts does nothing. Turning down the brightness and turning off dithering solves the problem.


(Patrick Cho) #19

Dymo wireless printer was in test for awhile and we pulled out due to instability of this product. The initially the Dymo Wireless Driver wasn’t installed and had a issue to print, but this doesn’t go further. Last Sunday, the printer was in test with one of help desk computer and it won’t print. It was working when we tested out with the same computer but it won’t print while the printer respond with ip address assign. It is bit mystery and I decide not to added in production yet. Our wireless network is in different VLAN vs wired computer VLAN. I am wondering if that is the issue. I will keep post it.


(Andy Baker) #20

Sounds good, thanks Patrick.
As far as printing to our model of Brother QL-810W from the new check in suite, we found the following error and forwarded to MP support for guidance on resolving it.

When attempting to print from Checkin Suite, the job errors out. PrintService/Operational logging and found the following when printing from Checkin Suite:

The print spooler failed to reopen an existing printer connection because it could not read the configuration information from the registry key S-1-5-20\Printers\Connections. The print spooler could not open the registry key. This can occur if the registry key is corrupt or missing, or if the registry recently became unavailable.

Immediately after clicking print, it’s assigned a job number, then that same registry key error occurs 4 times.

Could you point me in the right direction for troubleshooting this?