Internet Stream Drop

We’re currently having an issue with our Internet Stream and can’t pinpoint what’s causing it. We are currently using a Epiphan Pearl Encoder to stream our services via Stream Monkey. Right around Noon every Sunday (if we stream any other day it does the same thing around noon) the stream drops for just a second. It’s not always the exact time but within a few minutes of 12pm. On our end the encoder says it can’t see the server, and on the stream monkey’s end they see it disconnect. A user watching from home will have the stream stop and if they refresh it, it comes right back up. I’ve tried testing other video services at the time and don’t see an issue at the time (buffering could be a factor). Our streams to other campuses aren’t effected (2 of which are over EPL, the 3rd is using Living as One). We’ve tried eliminating network gear and had the stream box direct into our core switch and see no difference. We’ve taken the unit offsite and tested it and the stream continues through Noon without any issues.

Not sure how to pinpoint what’s causing the issue or where to go from here. Any suggestions?

Look and see if have a switch/router that is schedule to restart around that time.

We had a sonicwall firewall firmware that we updated to mid November that was causing odd things like this for our site to site broadcasts @benfifield could speak to specifics. We rolled the firmware back and all was good again. Now we are documenting it to explain to sonicwall.

may not be your issue but i’d check your firewall if it only happens on site.

Nothing else is effected though and even plugged directly into core switch>router it will still happen. We are monitoring all of our network equipment with Solarwinds and we know all of the other equipment is up at the time. We’ll get a large latency spike on a ping test to the device at the time the drop happens. Nothing else on the network shows the same latency spike at the time it happens (including the switch it’s plugged into).

@Jason.Lee Will check on the firmware on the firewall. We are using a Sonicwall. Do you know by chance what version of the firmware you had trouble with and/or rolled back to? @benfifield

We have a NSA 5600 HA pair. We had the issues on version I rolled it back to

The issues we had didn’t seem to be time-specific. In testing to find the issue, turning off the Content Filter service globally “fixed” the issue on 6.2.6. Obviously that’s not an acceptable fix, but since you know specifically when the issue comes up, you could try to turn it off a few minutes before to see if that’s it.

We don’t use the content filter as we are currently using OpenDNS Umbrella. We’re on a NSA 3500.

My experience with SonicWall (albeit limited) is that getting your features working reliably requires trying several firmwares until you get one that has the stuff you need working and sticking with it. That is unless you want to spend hours working with support and living with your devices not working correctly.

Went through firmware updates on the router and the Sonicawall. Today was the first day tested without the drop at noon. Going to test again tomorrow, but hopeful that we found the solution!

My suggestion was going to be to move all clocks on your network switches, routers, and firewalls ahead an hour and see if it happens at 1 PM instead :slight_smile: Glad you got it working.