Apple Server rejecting SMB clients overnight

HELP!!! I am running an Apple File Server on a Mac Mini server which has been running fine for years. Today I find out that that all of our Windows 10 clients are unable to connect in their usual way and no amount of discovery will make my file server appear to them on the network although every other networked device ie. printers, Xerox machines, are showing up as usual.

All of my Mac clients are functioning like usual. I suspect an overnight Windows update kicked in that caused this. There is no other connectivity problem for the PCs. They have access to the internet and email is running fine.

Any ideas!
Desperate in Honolulu

I confess to not being familiar enough with Apple File Server to know which version(s) of SMB it supports. Just wondered if the Windows machines were previously connecting with SMB v1? I know that recent W10 updates disable SMB v1 by default, for valid security reasons.

Not sure if that is the case here.

Is there a way to re-enable it for now?

what version of MacOS and Server App are you running?

Mac OSX 10.8.5
Server 2.2.5

Yes. However, if this is the actual problem, you really want to migrate to a newer version of SMB, ASAP.

https://www.google.com/amp/s/www.windowscentral.com/how-access-files-network-devices-using-smbv1-windows-10%3Famp

In this version of Server App, it should support SMB v2, but it may be that your Samba service is playing up.

First try downloading and using SMBUp to get Samba running again properly. Download from:
http://eduo.info/apps/smbup

However, as you probably know, your current version is way past and any kind of support from Apple, who also deprecated the Server App over 2 years ago, so it is no longer functional except to run Profile Manager. You should look ASAP to move to an alternative server platform such as Synology or similar type of NAS solution.

Thanks everyone! I got the problem fixed. Seems that the Sharing Preferences has a button buried several windows down that somehow got unchecked. In the File Sharing section there are two buttons that allow you to specify whether to use AFP or SMB or both. The SMB button was unchecked… Don’t know how that happened. Maybe something to do with all the power glitches we’ve been having here lately.

1 Like

Check to make sure that it wasn’t a Windows update that may have caused this (or an Apple update) so you are ready what to look for next time this happens.